고객센터네임서버
1588-5829
공지사항 > 고객센터 > 공지사항 > 공지사항
OpenSSL 다중 취약점 보안업데이트 권고
작 성 일 : 2014-10-23

 

개요

  • OpenSSL에서 발생한 메모리 고갈 취약점, 푸들(Poodle, Padding Oracle On Downloaded Legacy Encryption) 취약점 등 총 4개의 취약점을 보완한 보안업데이트를 발표함[1]

설명

  • DTLS SRTP 핸드쉐이크 메시지를 처리하는 중 발생하는 메모리 고갈 취약점 (CVE-2014-3513)
  • SSL/TLS/DTLS 서버에서 session ticket 값을 받을 때 발생하는 메모리 고갈 취약점 (CVE-2014-3567)
  • SSL3.0에서 다운 그레이드를 통해 MITM(man-in-the-middle)공격을 가능하게 하는 푸들(Poodle, Padding Oracle On Downloaded Legacy Encryption) 취약점 (CVE-2014-3566)
  • OpenSSL build option인 no-ssl3에서 발생한 취약점 (CVE-2014-3568)

해당 시스템

  • 영향 받는 제품 및 버전
    • OpenSSL 0.9.8 대 버전
    • OpenSSL 1.0.0 대 버전
    • OpenSSL 1.0.1 대 버전

해결 방안

  • 해당 취약점에 영향 받는 버전의 사용자는 아래 버전으로 업데이트[2]
    • OpenSSL 0.9.8 사용자 : 0.9.8zc로 업데이트
    • OpenSSL 1.0.0 사용자 : 1.0.0o로 업데이트
    • OpenSSL 1.0.1 사용자 : 1.0.1j로 업데이트

용어 설명

  • DTLS(Datagram Transport Layer Security) : 데이터 그램 전송계층을 보호하기 위한 UDP 기반 TLS 프로토콜
  • SRTP(Secure Real-time Transport Protocol) : 실시간으로 전송되는 멀티미디어 데이터를 암호화하여 송수신하는 프로토콜

 

 

[참고사이트]
[1] https://www.openssl.org/news/secadv_20141015.txt
[2] https://www.openssl.org/

 

목록